CircleCI Platform Status

Real-time health of CircleCI's own infrastructure and services.

Pipelines not triggering from VCS webhooks

Incident Report for CircleCI

Resolved

The incident is now resolved. Any PRs or commits that did not trigger a pipeline will not be re-run. Pipelines can be manually triggered in the CircleCI UI or by sending an empty commit using git's `--allow-empty` option.
Posted Aug 17, 2023 - 12:22 UTC

Update

We are continuing to see no further impact from this incident. Any PRs or commits that did not trigger a pipeline will not be re-run. Pipelines can be manually triggered in the CircleCI UI or by sending an empty commit using git's `--allow-empty` option.
Posted Aug 17, 2023 - 12:09 UTC

Monitoring

We have implemented a fix for the issue and we are now seeing pipelines triggering as normal. We are continuing to monitor the situation.
Posted Aug 17, 2023 - 11:52 UTC

Identified

We have identified the cause of the issue and are taking measures to mitigate the impact.
Posted Aug 17, 2023 - 11:50 UTC

Investigating

We have identified an issue causing VCS webhooks receiving a 500 error, causing pipelines to not be triggered in CircleCI. We are investigating to identify the cause.
Posted Aug 17, 2023 - 11:47 UTC
This incident affected: Pipelines & Workflows.