Customers are unable to view Releases information for their plans

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted Aug 21, 2024 - 18:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2024 - 18:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 21, 2024 - 17:54 UTC
This incident affected: CircleCI UI.